Acces checker red for full control users, inheritance check xml wrong

Jun 3, 2010 at 9:17 AM

When i check a full control or design user with the acces checker it will show everything red for them. If i check the generated XML i am able to see the user really has full control, but for some reason no acces on the below items. All the below items have the same inheritance as the site. Also all users are able to do everything they need full control or design rights for. It is also not only a site problem, but this is happening on all our site collections in our farm. This is a part of a example xml:

- <User>
<DisplayName>Bla, Bla</DisplayName>
<Login>Bla\blabal</Login>
</User>
<Access>Full Control</Access>
- <SPWeb>
<Title>/SiteOwnerTraining/WebParts</Title>
<Access>No</Access>
- <SPList>
<Title>Announcements</Title>
<ItemCount>0</ItemCount>
<Access>No</Access>
</SPList>
- <SPList>
<Title>Calendar</Title>
<ItemCount>0</ItemCount>
<Access>No</Access>
</SPList>

Now when i go to the inheritance checker, i will see the whole site in green as it should be. This time the XML will tells me that every list has unique permissions.
<SPWeb>
<Title>/SiteOwnerTraining/WebParts</Title>
<UniquePermissions>No</UniquePermissions>
- <SPList>
<Title>Announcements</Title>
<ItemCount>0</ItemCount>
<UniquePermissions>Yes</UniquePermissions>
</SPList>
- <SPList>
<Title>Calendar</Title>
<ItemCount>0</ItemCount>
<UniquePermissions>Yes</UniquePermissions>
</SPList>

I have really no idea when this started. I was told by a user that his rights where strange in the checker and when i keep checking it on several sites it is everywhere on every site collection we have. The user problem is only for full control and design users, all the others are being displayed right.

Any idea what this can be and better how to solve this one?